Build of OpenConnect 7.05+ for EL6?

Oliver Hernandez mr.oliver.hernandez at
Fri Jul 8 12:02:10 PDT 2016

What is the minimum version of p11-kit required to build?  I have
p11-kit-0.18.5-2.el6_5.2.x86_64 (and devel) packages installed, but
the rpmbuild is failing with:
error: Failed build dependencies:
pkgconfig(p11-kit) is needed by openconnect-7.06-1.el6.x86_64

Do I need to hunt down a newer version to install?

On Fri, Jul 8, 2016 at 12:08 PM, David Woodhouse <dwmw2 at> wrote:
> On Fri, 2016-07-08 at 10:34 -0400, Oliver Hernandez wrote:
>> Right now I'm stuck on the configure step of building OpenConnect.
>> Now, I'm building src rpm from the link you posted Nikos with the EL6
>> release of OpenConnect, if that makes a difference.  I'm getting
>> warnings that my version of GnuTLS is too old, and that my version of
>> OpenSSL is known to be broken with Cisco DTLS.  I'm running RHEL6
>> configured to use a local repo on our corporate network, and there are
>> no updates to either of these packages.  Am I required to have to find
>> updated versions of one of these packages to proceed?
> No, just use --without-openssl-version-check on the configure command line.
> The bug is fixed in the RHEL6 OpenSSL package, so it should be fine.
> --
> dwmw2

More information about the openconnect-devel mailing list