SSL connection failure: Error in the pull function.

Chad Bishop chadjbishop at
Fri Apr 8 10:48:29 PDT 2016


We recently updated our vpn server to "use a more secure version of
TLS" least that's what I'm told.  In doing so, I'm now unable to
make a connection using openconnect on Fedora 20.

The command I'm using is:

sudo openconnect [IP] --no-cert-check

The only output I get is:

Attempting to connec to server [IP]
SSL negotiation with [IP]
SSL connection failure: Error in the pull function.
Failed to open HTTPS connection to [IP]
Failed to obtain WebVPN cookie

I tried updating to the latest version of GnuTLS and that didn't seem to help.

I've tried to compile openconnect without gnutls, but get a configure
error that "This version of OpenSSL is known to be broken with Cisco
DTLS".  I'm not sure why as the latest version of OpenSSL is installed
so it must be looking at an older location/version than the default.

Are there any other debug commands or log locations I can check to see
what's going on?

Thanks much for any help,


More information about the openconnect-devel mailing list