openconnect and no-xmlpost parameter

Sérgio Durand linux at
Tue Sep 15 19:57:26 PDT 2015

Hi !

I'm trying to connect to our corporate VPN but it only works using
--no-xmlpost parameter.
My tests with openconnect 7.06 fails if I don't use --no-xmlpost
("Failed to obtain WebVPN cookie").
I also tried the latest commit available in GIT, same problem.

It stop working after openconnect 5.03.
OC 5.03 works fine without --no-xmlpost.
In fact, reading the code I see that it first tries to use xmlpost,
then fails, but automatically it tries again setting vpninfo->xmlpost
to 0, then work.

In openconnect manual page there is a mention if --no-xmlpost is
needed it is because there is a bug.
So, here we are :)

Before write this mail I tried to identify what could be going wrong.
I have debugged the cstp_obtain_cookie() function of auth.c file.

I believe the problem could be there.
More specifically in the Step 2 block.
BTW, there is no Step 3 in the source code. It jumps to Step 4 :)

Any suggestion what could be my next steps ?

Thanks !
Sergio H. M. Durand

More information about the openconnect-devel mailing list