juniper ssl error

Cameron Berkenpas cam at
Mon Oct 12 13:14:04 PDT 2015

Thank you for the fast response.

When I try to use --gnutls-debug, I get:
unrecognized option '--gnutls-debug=99'

Turns out I didn't openconnect with gnutls... So I rebuilt openconnect 
with gnutls, and ran it again... Now it works!

Strangely, the openconnect script still doesn't show --gnutls-debug as 
an available option.

Is gnutls explicitly required for juniper support? I don't see any 
documentation for it...

Anyway, thanks your help! I haven't been able to use my VPN for a week, 
and now it works again. It works better than before as I don't need to 
use that awful network connect. You are a man among men!

Do you accept donations? I don't see a link on your site...


On 10/12/2015 12:08 AM, David Woodhouse wrote:
> On Sun, 2015-10-11 at 13:07 -0700, Cameron Berkenpas wrote:
>> SSL negotiation with <juniper-host>
>> SSL connection failure
>> Creating SSL connection failed
> It's failing even to negotiate the SSL connection. Can you try again
> with --gnutls-debug=99?

More information about the openconnect-devel mailing list