ocserv installation on debian (arm)

Nikos Mavrogiannopoulos n.mavrogiannopoulos at gmail.com
Thu Apr 30 02:19:00 PDT 2015

On Thu, Apr 30, 2015 at 10:41 AM, Mauro Gaspari <ilvipero at dazuzu.com> wrote:
> Hello
> I recently found this project, and it looks very interesting. I have
> been trying to install versions 0.10.2, 0.10.3, and 0.10.4 on a few
> machines (and virtual machines) based on debian, ubuntu, and openSUSE.
> So far, I had no issues on x86 or x86_64, but I was not able to
> complete the "make" process on arm architecture (debian).
> I have a couple of testing boards, banana pi bpi-r1 with bananian
> installed (debian 7 arm).
> 1. First issue was with debian wheezy dependencies. wheezy backports
> repository (deb http://http.debian.net/debian wheezy-backports main)
> includes the needed package "libgnutls28-dev" for the x86 and x86_64
> architectures, but not for armhf yet.
> Since I am on testing phase, I quickly resolved changing my repos from
> wheezy to testing. I am pretty sure this will be solved in the future,
> just wanted to report that, hopefully it helps someone.
> 2. once all dependencies were installed, I tried to install ocserv by
> running ./configure --prefix=/usr --sysconfdir=/etc && make && make
> install
> this works perfectly on x86 and x86_64, but fails on arm. I have all
> required packages per README file. Since the output is very long, I
> will only paste a few lines here.
> Any help will be greatly appreciated.I am available to help for
> further testing, troubleshooting. If needed I can connect one spare
> device to a public IP and provide remote access for as long as it
> takes.

For non-x86/x86-64 systems it matters to have the latest libseccomp.
If you have it and you still see that issue, most probably your
platform isn't supported by seccomp. You'll have to use
"--disable-seccomp" with configure.


More information about the openconnect-devel mailing list