problem about openconnect6.0 Windows client

David Woodhouse dwmw2 at
Thu Jul 24 06:30:21 PDT 2014

On Thu, 2014-07-24 at 19:59 +0800, 飞翔 wrote:
> Hi,
>  I have compiled the openconnect6.0.0.tar.gz on Fedora 20 in VMVare successfully,
>  And I have download and install the latest openvpn driver on  Windows 7 system.
>  but a problem happens when I run it on Windows
> Question 1:
>  The pictures 1.jpg , 2.jpg, 3.jpg, 4.jpg, 5.jpg  show the problem:
>  When I do what the picture 1 shows , I seems that everything is  OK,but just like the picture 2,3,4  show,
>  the Local Area Connection will fails to identify at last.
>  So,what is the problem?  5.jpg is the route talbe :

I believe this was fixed in the git tree shortly after the 6.00 release:

> Question 2:
>     When I run it on XP,the openconnect client will show a error dialog(can't find Entry RegGetValueA in ADVAPI32.dll).
>     so,does the openconnect6.0 client for Windows support for XP?

Hm, I think we need to use RegQueryValueEx() instead of RegGetValue(),
which should be a relatively simple change... want to test and submit a
patch for that?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5745 bytes
Desc: not available
URL: <>

More information about the openconnect-devel mailing list