[PATCH 1/2] staging: bcm2835-audio: Replace call to vchi_msg_queue with vchi_queue_kernel_message
Stefan Wahren
stefan.wahren at i2se.com
Wed Feb 1 09:04:33 PST 2017
Am 01.02.2017 um 15:31 schrieb Michael Zoran:
> The function vchi_msg_queue was made static in vc04_services
> and replaced with vchi_queue_kernel_message.
>
> Change the call to vchi_msg_queue to vchi_queue_kernel_message
>
> Signed-off-by: Michael Zoran <mzoran at crowfest.net>
> ---
> drivers/staging/bcm2835-audio/bcm2835-vchiq.c | 15 +++------------
> 1 file changed, 3 insertions(+), 12 deletions(-)
>
> diff --git a/drivers/staging/bcm2835-audio/bcm2835-vchiq.c b/drivers/staging/bcm2835-audio/bcm2835-vchiq.c
> index e8fd9c79bcfc..7c952bae4e52 100644
> --- a/drivers/staging/bcm2835-audio/bcm2835-vchiq.c
> +++ b/drivers/staging/bcm2835-audio/bcm2835-vchiq.c
> @@ -81,23 +81,14 @@ static int bcm2835_audio_write_worker(struct bcm2835_alsa_stream *alsa_stream,
>
> // Routine to send a message across a service
>
> -static ssize_t
> -bcm2835_vchi_msg_queue_callback(void *context, void *dest,
> - size_t offset, size_t maxsize)
> -{
> - memcpy(dest, context + offset, maxsize);
> - return maxsize;
> -}
> -
> static int
> bcm2835_vchi_msg_queue(VCHI_SERVICE_HANDLE_T handle,
> void *data,
> unsigned int size)
> {
> - return vchi_msg_queue(handle,
> - bcm2835_vchi_msg_queue_callback,
> - data,
> - size);
> + return vchi_queue_kernel_message(handle,
> + data,
> + size);
> }
>
How about calling vchi_queue_kernel_message directly in the driver and
get the rid of bcm2835_vchiq_msg_queue, too?
More information about the linux-rpi-kernel
mailing list