[PATCH v3 5/6] powercap: dtpm: Rename Rockchip virtual node descriptor
Daniel Lezcano
daniel.lezcano at oss.qualcomm.com
Tue Oct 20 07:16:55 PDT 2026
The virtual DTPM node descriptor is named after the RK3399 even though
it does not contain any SoC-specific information.
Rename it to rockchip_virtual so it can be reused by other Rockchip SoC
hierarchies.
No functional change intended.
Assisted-by: LLM
Signed-off-by: Daniel Lezcano <daniel.lezcano at oss.qualcomm.com>
---
Changes in v3 (since v2):
- Rebase on v7.3-rc7 and refresh context after patch 4 style cleanup.
- Add Assisted-by attribution; no functional changes.
drivers/soc/rockchip/dtpm.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/soc/rockchip/dtpm.c b/drivers/soc/rockchip/dtpm.c
index 222d9098cc98..5ae00680602f 100644
--- a/drivers/soc/rockchip/dtpm.c
+++ b/drivers/soc/rockchip/dtpm.c
@@ -11,7 +11,7 @@
#include <linux/of.h>
#include <linux/platform_device.h>
-static struct dtpm_node rk3399_virtual = {
+static struct dtpm_node rockchip_virtual = {
.type = DTPM_NODE_VIRTUAL,
};
@@ -33,12 +33,12 @@ static struct dtpm_node rk3399_gpu = {
static struct powercap_node rk3399_nodes[] __initdata = {
[0] = {
.name = "rk3399",
- .data = &rk3399_virtual,
+ .data = &rockchip_virtual,
},
[1] = {
.name = "package",
.parent = &rk3399_nodes[0],
- .data = &rk3399_virtual,
+ .data = &rockchip_virtual,
},
[2] = {
.name = "cpu0-cpufreq",
--
2.43.0
More information about the Linux-rockchip
mailing list