[PATCH v3 00/12]
Niklas Cassel
cassel at kernel.org
Mon Oct 7 03:02:18 PDT 2024
On Mon, Oct 07, 2024 at 01:12:06PM +0900, Damien Le Moal wrote:
> This patch series is the second part of the former version 2 of the
> patch series "Improve PCI memory mapping API". This second part is split
> out as it deals solely with the rockchip/rk3399 PCI endpoint controller
> driver.
Since this series depends on:
[1] https://lore.kernel.org/linux-pci/20241007040319.157412-1-dlemoal@kernel.org/
I think that you should have added a link to that series in this cover letter,
and more clearly state that this series depends on [1].
(Right now, someone might think that this series could be applied standalone.)
Kind regards,
Niklas
>
> This series is organized as follows:
> - Patch 1 fixes the rockchip ATU programming
> - Patch 2, 3 and 4 introduce small code improvments
> - Patch 5 implements the .map_align() operation to make the rk3399
> endpoint controller driver fully functional
> - Patch 6, 7 and 8 refactor the driver code to make it more readable
> - Patch 9 introduces the .stop() endpoint controller operation to
> correctly disable the endpopint controller after use
> - Patch 10 improves link training
> - Patch 11 and 12 implement handling of the #PERST signal
>
> Changes from v2:
> - Split the patch series
> - Corrected patch 11 to add the missing "maxItem"
>
> Changes from v1:
> - Changed pci_epc_check_func() to pci_epc_function_is_valid() in patch
> 1.
> - Removed patch "PCI: endpoint: Improve pci_epc_mem_alloc_addr()"
> (former patch 2 of v1)
> - Various typos cleanups all over. Also fixed some blank space
> indentation.
> - Added review tags
>
> Damien Le Moal (11):
> PCI: rockchip-ep: Fix address translation unit programming
> PCI: rockchip-ep: Use a macro to define EP controller .align feature
> PCI: rockchip-ep: Improve rockchip_pcie_ep_unmap_addr()
> PCI: rockchip-ep: Improve rockchip_pcie_ep_map_addr()
> PCI: rockchip-ep: Implement the .map_align() controller operation
> PCI: rockchip-ep: Refactor rockchip_pcie_ep_probe() memory allocations
> PCI: rockchip-ep: Refactor rockchip_pcie_ep_probe() MSI-X hiding
> PCI: rockchip-ep: Refactor endpoint link training enable
> PCI: rockship-ep: Introduce rockchip_pcie_ep_stop()
> PCI: rockchip-ep: Improve link training
> PCI: rockchip-ep: Handle PERST# signal in endpoint mode
>
> Wilfred Mallawa (1):
> dt-bindings: pci: rockchip,rk3399-pcie-ep: Add ep-gpios property
>
> .../bindings/pci/rockchip,rk3399-pcie-ep.yaml | 4 +
> drivers/pci/controller/pcie-rockchip-ep.c | 392 +++++++++++++++---
> drivers/pci/controller/pcie-rockchip.c | 17 +-
> drivers/pci/controller/pcie-rockchip.h | 22 +
> 4 files changed, 358 insertions(+), 77 deletions(-)
>
> --
> 2.46.2
>
More information about the Linux-rockchip
mailing list