[PATCH v2 10/12] staging: media: rkvdec: Wrapper for pixel format preparation
Andrzej Pietrasiewicz
andrzej.p at collabora.com
Mon Jan 16 02:42:15 PST 2023
Hi Sebastian,
W dniu 12.01.2023 o 13:56, Sebastian Fricke pisze:
> Reduce code duplication by creating a wrapper around the preparation of
> the `v4l2_pix_format_mplane` structure and the calculation of the
> image size.
>
> Signed-off-by: Sebastian Fricke <sebastian.fricke at collabora.com>
> ---
> drivers/staging/media/rkvdec/rkvdec.c | 29 +++++++++++++++--------------
> 1 file changed, 15 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/staging/media/rkvdec/rkvdec.c b/drivers/staging/media/rkvdec/rkvdec.c
> index 8d948bcc4e46..b303c6e0286d 100644
> --- a/drivers/staging/media/rkvdec/rkvdec.c
> +++ b/drivers/staging/media/rkvdec/rkvdec.c
> @@ -27,6 +27,17 @@
> #include "rkvdec.h"
> #include "rkvdec-regs.h"
>
> +static void rkvdec_fill_decoded_pixfmt(struct rkvdec_ctx *ctx,
> + struct v4l2_pix_format_mplane *pix_mp)
> +{
> + v4l2_fill_pixfmt_mp(pix_mp, pix_mp->pixelformat,
> + pix_mp->width, pix_mp->height);
> + pix_mp->plane_fmt[0].sizeimage += 128 *
> + DIV_ROUND_UP(pix_mp->width, 16) *
> + DIV_ROUND_UP(pix_mp->height, 16);
> + pix_mp->field = V4L2_FIELD_NONE;
> +}
> +
> static int rkvdec_queue_busy(struct rkvdec_ctx *ctx, enum v4l2_buf_type buf_type)
> {
> struct vb2_queue *vq;
> @@ -248,13 +259,9 @@ static void rkvdec_reset_decoded_fmt(struct rkvdec_ctx *ctx)
>
> rkvdec_reset_fmt(ctx, f, valid_fmt);
> f->type = V4L2_BUF_TYPE_VIDEO_CAPTURE_MPLANE;
> - v4l2_fill_pixfmt_mp(&f->fmt.pix_mp,
> - ctx->coded_fmt_desc->decoded_fmts[0],
> - ctx->coded_fmt.fmt.pix_mp.width,
> - ctx->coded_fmt.fmt.pix_mp.height);
> - f->fmt.pix_mp.plane_fmt[0].sizeimage += 128 *
> - DIV_ROUND_UP(f->fmt.pix_mp.width, 16) *
> - DIV_ROUND_UP(f->fmt.pix_mp.height, 16);
> + f->fmt.pix_mp.width = ctx->coded_fmt.fmt.pix_mp.width;
> + f->fmt.pix_mp.height = ctx->coded_fmt.fmt.pix_mp.height;
> + rkvdec_fill_decoded_pixfmt(ctx, &f->fmt.pix_mp);
Strictly technically this function has _not_ been setting pix_mt->field
to V4L2_FIELD_NONE, but after this change there exists such a "side effect".
Maybe it is actually desired, or maybe it being missing in the not patched
version was a mistake in the first place. Just letting you know so that
you can make sure pix_mp->field being actually set now is ok in the context
of rkvdec_queue_busy().
Regards,
Andrzej
> }
>
> static int rkvdec_enum_framesizes(struct file *file, void *priv,
> @@ -324,13 +331,7 @@ static int rkvdec_try_capture_fmt(struct file *file, void *priv,
> &pix_mp->height,
> &coded_desc->frmsize);
>
> - v4l2_fill_pixfmt_mp(pix_mp, pix_mp->pixelformat,
> - pix_mp->width, pix_mp->height);
> - pix_mp->plane_fmt[0].sizeimage +=
> - 128 *
> - DIV_ROUND_UP(pix_mp->width, 16) *
> - DIV_ROUND_UP(pix_mp->height, 16);
> - pix_mp->field = V4L2_FIELD_NONE;
> + rkvdec_fill_decoded_pixfmt(ctx, pix_mp);
>
> return 0;
> }
>
More information about the Linux-rockchip
mailing list