[Bug 13426] booting with Prism2/2.5 PCMCIA card inserted crashes hard

bugzilla-daemon at bugzilla.kernel.org bugzilla-daemon at bugzilla.kernel.org
Thu Jan 14 07:26:19 EST 2010


--- Comment #10 from Wim Osterholt <wim at djo.tudelft.nl>  2010-01-14 12:26:15 ---
bugzilla-daemon at bugzilla.kernel.org zei ooit: 
>Date: Tue, 2 Jun 2009 01:21:36 GMT
>From: bugzilla-daemon at bugzilla.kernel.org
>Subject: [Bug 13426] New: booting with Prism2/2.5 PCMCIA card inserted crashes hard

> http://bugzilla.kernel.org/show_bug.cgi?id=13426
>            Summary: booting with Prism2/2.5 PCMCIA card inserted crashes
>                     hard
>            Product: Drivers
>            Version: 2.5
>     Kernel Version: 2.6.27-r10
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: PCMCIA
>         AssignedTo: linux-pcmcia at lists.infradead.org
>         ReportedBy: wim at djo.tudelft.nl
>                 CC: wim at djo.tudelft.nl
>         Regression: No
> While inserting any Prism2/2.5 PCMICIA card in a running system (kernel
> 2.6.27-r10) works perfectly with hostap_cs.ko, leaving the card inserted during
> a reboot will crash hard, leaving the machine locked up with all LEDs flashing.
> I've not yet written down all the goobledigook it leaves on the screen.
> (Not sure its the same every time.)
> Regards, Wim.

Thanks for the progress.
Up until kernel 2.6.33.-rc3 this behaviour remains the same. The errors
before lockup are none, process pcmcia, process modprobe, divide error, and
presumably the important one: do_IRQ  No irq handler for vector (irq -1).

The amazing thing is that hostap _works_ at insertion after the login prompt.
Moving the kernel and modules to another laptop (Dell Inspiron 4100) shows
_always_ a lockup at insertion of the card.
The error then is always: do_IRQ:0176  No irq handler for vector (irq -1)

Since I found a kernel 2.6.30-r8 (gentoo) that worked fine on the Dell with
that card, it must be that there is a configurational bug involved.
The Dell is much faster in compiling kernels. Eliminating the different
configure options one by one I came to the point where the Dell would always
work when I have the option CONFIG_DEBUG_SHIRQ unset.
The explanation of this option has no big fat warning, so a layman like me
would turn it on because I have a problem to debug. This is one
configurational kernel bug to begin with. The description holds only a faint
hint that the driver should handle the problem.
So, there's also clearly a bug in hostap!

Now I've another problem. The option CONFIG_DEBUG_SHIRQ is not set in all
the kernels on my Thinkpad. So there must be more of these dangerous
configure options. :-(

The 'good' kernel 2.6.30-r8 has not yet been tried on the thinkpad.
(must be recompiled for the lower CPU of the thinkpad).

Regards, Wim.

----- wim at djo.tudelft.nl -----

Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the linux-pcmcia mailing list