Problem with Advantech COMpad2 pcmcia card with pcmciautils

Kenneth Moorman KMoorman at
Tue May 5 23:50:40 EDT 2009

A while back, I was using an Ubuntu system with a 
2.4 kernel.   I was able to get a dual serial 
port PCMCIA card from Advantech to work w/o 
too much problem using the old pcmcia-cs tools. 

The config file in /etc/pcmcia contained the following

card "Advantech COMpad-32/85B-2"
  version "ADVANTECH", "COMpad-32/85B-2"
  cis "cis/COMpad2.dat"
  bind "serial_cs"

card "Advantech COMpad-32/85B-4"
  version "ADVANTECH", "COMpad-32/85B-4"
  cis "cis/COMpad4.dat"
  bind "serial_cs"

#card "Advantech COMpad-32/85"
#  version "ADV", "*", "TECH", "COMpad-32/85"
#  bind "serial_cs"

card "Advantech COMpad-32/85B-2"
  version "ADV", "*", "TECH", "COMpad-32/85B-2"
  bind "serial_cs"

When the card was inserted, it was correctly bound
to the serial_cs and two new ttyS's showed up 
that I could access. 

A student updated the system to XUbuntu 8.04
which is using a 2.6 kernel (2.6.24-24). 
With the new pcmciautils, I cannot get the 
card to work. 

Here's what I have tried.  I copied the
COMpad2.dat file from /etc/pcmcia/cis directory
(I had a backup) to /lib/firmware/COMpad2.cis

I added the above entries to the config.opts
file in /etc/pcmcia.   However, the card
shows up as being bound to parport_cs.

I manually loaded the serial_cs module.
Same result.   I tries changing the cis
line to cis "COMpad2.cis"
I tried several other variations, even
the absolute path name.

Any advice, stupid things I have overlooked, etc?
I tried removing the entries except for the
first one that refers to this specific card.
I tried various wildcards.

I have acquired a USB to serial adaptor and am
currently using it along with the one built-in
port.  But this is nagging me---it *should*
work, right?


Successfully Scanned by the McAfee SIG 3200 Appliance.

More information about the linux-pcmcia mailing list