[PATCH v10 06/24] iommu/dma: Factor out a iommu_dma_map_swiotlb helper

Baolu Lu baolu.lu at linux.intel.com
Mon Apr 28 21:58:18 PDT 2025


On 4/28/25 17:22, Leon Romanovsky wrote:
> From: Christoph Hellwig<hch at lst.de>
> 
> Split the iommu logic from iommu_dma_map_page into a separate helper.
> This not only keeps the code neatly separated, but will also allow for
> reuse in another caller.
> 
> Signed-off-by: Christoph Hellwig<hch at lst.de>
> Tested-by: Jens Axboe<axboe at kernel.dk>
> Reviewed-by: Luis Chamberlain<mcgrof at kernel.org>
> Signed-off-by: Leon Romanovsky<leonro at nvidia.com>

Reviewed-by: Lu Baolu <baolu.lu at linux.intel.com>

with a nit below ...

> ---
>   drivers/iommu/dma-iommu.c | 73 ++++++++++++++++++++++-----------------
>   1 file changed, 41 insertions(+), 32 deletions(-)
> 
> diff --git a/drivers/iommu/dma-iommu.c b/drivers/iommu/dma-iommu.c
> index d3211a8d755e..d7684024c439 100644
> --- a/drivers/iommu/dma-iommu.c
> +++ b/drivers/iommu/dma-iommu.c
> @@ -1138,6 +1138,43 @@ void iommu_dma_sync_sg_for_device(struct device *dev, struct scatterlist *sgl,
>   			arch_sync_dma_for_device(sg_phys(sg), sg->length, dir);
>   }
>   
> +static phys_addr_t iommu_dma_map_swiotlb(struct device *dev, phys_addr_t phys,
> +		size_t size, enum dma_data_direction dir, unsigned long attrs)
> +{
> +	struct iommu_domain *domain = iommu_get_dma_domain(dev);
> +	struct iova_domain *iovad = &domain->iova_cookie->iovad;
> +
> +	if (!is_swiotlb_active(dev)) {
> +		dev_warn_once(dev, "DMA bounce buffers are inactive, unable to map unaligned transaction.\n");
> +		return (phys_addr_t)DMA_MAPPING_ERROR;
> +	}
> +
> +	trace_swiotlb_bounced(dev, phys, size);
> +
> +	phys = swiotlb_tbl_map_single(dev, phys, size, iova_mask(iovad), dir,
> +			attrs);
> +
> +	/*
> +	 * Untrusted devices should not see padding areas with random leftover
> +	 * kernel data, so zero the pre- and post-padding.
> +	 * swiotlb_tbl_map_single() has initialized the bounce buffer proper to
> +	 * the contents of the original memory buffer.
> +	 */
> +	if (phys != (phys_addr_t)DMA_MAPPING_ERROR && dev_is_untrusted(dev)) {
> +		size_t start, virt = (size_t)phys_to_virt(phys);
> +
> +		/* Pre-padding */
> +		start = iova_align_down(iovad, virt);
> +		memset((void *)start, 0, virt - start);
> +
> +		/* Post-padding */
> +		start = virt + size;
> +		memset((void *)start, 0, iova_align(iovad, start) - start);
> +	}
> +
> +	return phys;
> +}
> +
>   dma_addr_t iommu_dma_map_page(struct device *dev, struct page *page,
>   	      unsigned long offset, size_t size, enum dma_data_direction dir,
>   	      unsigned long attrs)
> @@ -1151,42 +1188,14 @@ dma_addr_t iommu_dma_map_page(struct device *dev, struct page *page,
>   	dma_addr_t iova, dma_mask = dma_get_mask(dev);
>   
>   	/*
> -	 * If both the physical buffer start address and size are
> -	 * page aligned, we don't need to use a bounce page.
> +	 * If both the physical buffer start address and size are page aligned,
> +	 * we don't need to use a bounce page.
>   	 */
>   	if (dev_use_swiotlb(dev, size, dir) &&
>   	    iova_offset(iovad, phys | size)) {
> -		if (!is_swiotlb_active(dev)) {

... Is it better to move this check into the helper? Simply no-op if a
bounce page is not needed:

	if (!dev_use_swiotlb(dev, size, dir) ||
	    !iova_offset(iovad, phys | size))
		return phys;

Thanks,
baolu



More information about the Linux-nvme mailing list