[PATCH v9 15/24] vfio/mlx5: Explicitly use number of pages instead of allocated length
Jason Gunthorpe
jgg at ziepe.ca
Wed Apr 23 10:39:59 PDT 2025
On Wed, Apr 23, 2025 at 11:13:06AM +0300, Leon Romanovsky wrote:
> From: Leon Romanovsky <leonro at nvidia.com>
>
> allocated_length is a multiple of page size and number of pages,
> so let's change the functions to accept number of pages. It opens
> us a venue to combine receive and send paths together with code
> readability improvement.
>
> Tested-by: Jens Axboe <axboe at kernel.dk>
> Signed-off-by: Leon Romanovsky <leonro at nvidia.com>
> ---
> drivers/vfio/pci/mlx5/cmd.c | 32 ++++++++++-----------
> drivers/vfio/pci/mlx5/cmd.h | 10 +++----
> drivers/vfio/pci/mlx5/main.c | 56 +++++++++++++++++++++++-------------
> 3 files changed, 57 insertions(+), 41 deletions(-)
Reviewed-by: Jason Gunthorpe <jgg at nvidia.com>
Jason
More information about the Linux-nvme
mailing list