[PATCH] nvme: use BIT_MASK and GENMASK for NVME definitions
Christoph Hellwig
hch at infradead.org
Mon Nov 11 20:26:51 PST 2024
> - NVME_CMBSZ_CQS = 1 << 1,
> - NVME_CMBSZ_LISTS = 1 << 2,
> - NVME_CMBSZ_RDS = 1 << 3,
> - NVME_CMBSZ_WDS = 1 << 4,
> + NVME_CMBSZ_SQS = BIT_MASK(0),
> + NVME_CMBSZ_CQS = BIT_MASK(1),
> + NVME_CMBSZ_LISTS = BIT_MASK(2),
> + NVME_CMBSZ_RDS = BIT_MASK(3),
> + NVME_CMBSZ_WDS = BIT_MASK(4),
Nothjing genmask here, and a lot less readable for no good reason at
all.
> NVME_CMBSZ_SZ_SHIFT = 12,
> - NVME_CMBSZ_SZ_MASK = 0xfffff,
> + NVME_CMBSZ_SZ_MASK = GENMASK(19, 0),
This is using the GENMASK that you mentioned, and now I actually
need to look up what GENMASK does to decipher the previously perfectly
understandable code.
Could people please stop sending or suggesting cleanups that make
the code much worse?
More information about the Linux-nvme
mailing list