[PATCH v7 06/10] io_uring/rw: add support to send metadata along with read/write
Christoph Hellwig
hch at lst.de
Tue Nov 5 22:12:41 PST 2024
On Wed, Nov 06, 2024 at 11:30:45AM +0530, Kanchan Joshi wrote:
> > 1) some space to actually store the extra fields
> > 2) a flag that the additional values are passed
>
> Yes, this is exactly how the patch is implemented. 'meta-type' is the
> flag that tells additional values (representing PI info) are passed.
>
> > any single value is not going to help with supporting arbitrary
> > combinations,
>
> Not a single value. It is a u16 field, so it can represent 16 possible
> flags.
> This part in the patch:
>
> +enum io_uring_sqe_meta_type_bits {
> + META_TYPE_PI_BIT,
> + /* not a real meta type; just to make sure that we don't overflow */
> + META_TYPE_LAST_BIT,
> +};
Well, then it's grossly misnamed and underdocumented. For one the
meta name simply is wrong because it's about all extra features.
Second a type implies an enumeration of types, not a set of flags.
So if you actually name this extended_features or similar and clearly
document it might actually make sense.
More information about the Linux-nvme
mailing list