[PATCH 01/32] block: Provide blkdev_get_handle_* functions
Christoph Hellwig
hch at infradead.org
Thu Jul 6 08:38:40 PDT 2023
On Tue, Jul 04, 2023 at 02:21:28PM +0200, Jan Kara wrote:
> Create struct bdev_handle that contains all parameters that need to be
> passed to blkdev_put() and provide blkdev_get_handle_* functions that
> return this structure instead of plain bdev pointer. This will
> eventually allow us to pass one more argument to blkdev_put() without
> too much hassle.
Can we use the opportunity to come up with better names? blkdev_get_*
was always a rather horrible naming convention for something that
ends up calling into ->open.
What about:
struct bdev_handle *bdev_open_by_dev(dev_t dev, blk_mode_t mode, void *holder,
const struct blk_holder_ops *hops);
struct bdev_handle *bdev_open_by_path(dev_t dev, blk_mode_t mode,
void *holder, const struct blk_holder_ops *hops);
void bdev_release(struct bdev_handle *handle);
?
More information about the Linux-nvme
mailing list