[PATCH 0/3] nvme: rework __nvme_submit_sync_cmd()
Hannes Reinecke
hare at suse.de
Wed Feb 8 00:49:36 PST 2023
Hi all,
as Jens and hch complained about the argument list to __nvme_submit_sync_cmd()
getting too long, here's now a patchset to clean things up.
The first patch is to split off __nvme_alloc_rq() from __nvme_submit_sync_cmd(),
which serves to reduce the number of arguments; it's also a nice cleanup as this
function can be utilized to replace some open-coded versions.
The second patch is to introduce a 'retry' argument to __nvme_alloc_rq(), to
indicate whether retries for this command should be allowd.
And the third is another cleanup; the 'at_head' argument to __nvme_submit_sync_cmd()
really should be a boolean, as it can take only two values, and it's being
converted into a boolean within __nvme_submit_sync_cmd() anyway.
As usual, comments and reviews are welcome.
Hannes Reinecke (3):
nvme: split __nvme_submit_sync_cmd()
nvme: retry internal commands if DNR status bit is not set
nvme: make 'at_head' parameter for __nvme_submit_sync_cmd() boolean
drivers/nvme/host/auth.c | 10 ++++--
drivers/nvme/host/core.c | 65 ++++++++++++++++++++++------------
drivers/nvme/host/fabrics.c | 46 +++++++++++++++++-------
drivers/nvme/host/ioctl.c | 2 +-
drivers/nvme/host/nvme.h | 11 +++---
drivers/nvme/host/pci.c | 9 +++--
drivers/nvme/target/passthru.c | 3 +-
7 files changed, 96 insertions(+), 50 deletions(-)
--
2.35.3
More information about the Linux-nvme
mailing list