[PATCH v3 4/4] block: ublk_drv: Add a helper instead of casting
Christoph Hellwig
hch at lst.de
Sun Apr 30 21:31:22 PDT 2023
On Sun, Apr 30, 2023 at 07:35:32AM -0700, Breno Leitao wrote:
> ublk driver is using casts to get private data from uring cmd struct.
> Let's use a proper helper, as an interface that requires casts in all
> callers is one asking for bugs.
>
> Suggested-by: Christoph Hellwig <hch at lst.de>
No, I've not suggested this.
> +static inline struct ublksrv_ctrl_cmd *ublk_uring_ctrl_cmd(
> + struct io_uring_cmd *cmd)
> +{
> + return (struct ublksrv_ctrl_cmd *)cmd->sqe->cmd;
> +}
I've two times explained we need a core io_uring helper to remove this
casting in the drivers, and I've explained how to do that and provided
the actual code for it.
More information about the Linux-nvme
mailing list