[PATCH for-next v12 08/12] block: rename bio_map_put to blk_mq_map_bio_put
Anuj Gupta
anuj20.g at samsung.com
Thu Sep 29 23:27:45 PDT 2022
This patch renames existing bio_map_put function to blk_mq_map_bio_put.
Signed-off-by: Anuj Gupta <anuj20.g at samsung.com>
Suggested-by: Christoph Hellwig <hch at lst.de>
Reviewed-by: Christoph Hellwig <hch at lst.de>
---
block/blk-map.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/block/blk-map.c b/block/blk-map.c
index 0e37bbedd46c..84b13a4158b7 100644
--- a/block/blk-map.c
+++ b/block/blk-map.c
@@ -231,7 +231,7 @@ static int bio_copy_user_iov(struct request *rq, struct rq_map_data *map_data,
return ret;
}
-static void bio_map_put(struct bio *bio)
+static void blk_mq_map_bio_put(struct bio *bio)
{
if (bio->bi_opf & REQ_ALLOC_CACHE) {
bio_put(bio);
@@ -331,7 +331,7 @@ static int bio_map_user_iov(struct request *rq, struct iov_iter *iter,
out_unmap:
bio_release_pages(bio, false);
- bio_map_put(bio);
+ blk_mq_map_bio_put(bio);
return ret;
}
@@ -672,7 +672,7 @@ int blk_rq_unmap_user(struct bio *bio)
next_bio = bio;
bio = bio->bi_next;
- bio_map_put(next_bio);
+ blk_mq_map_bio_put(next_bio);
}
return ret;
--
2.25.1
More information about the Linux-nvme
mailing list