[PATCHv6 05/11] block: add a helper function for dio alignment

Bart Van Assche bvanassche at acm.org
Fri Jul 22 14:53:25 PDT 2022


On 6/10/22 12:58, Keith Busch wrote:
> +static bool blkdev_dio_unaligned(struct block_device *bdev, loff_t pos,
> +			      struct iov_iter *iter)
> +{
> +	return ((pos | iov_iter_alignment(iter)) &
> +	    (bdev_logical_block_size(bdev) - 1));
> +}

A nit: if you have to repost this patch series, please leave out the 
outer parentheses from the return statement. Otherwise this patch looks 
good to me.

Thanks,

Bart.



More information about the Linux-nvme mailing list