[PATCH 08/30] target/iblock: use bdev_nr_bytes instead of open coding it
Kees Cook
keescook at chromium.org
Fri Oct 15 08:57:59 PDT 2021
On Fri, Oct 15, 2021 at 03:26:21PM +0200, Christoph Hellwig wrote:
> Use the proper helper to read the block device size.
>
> Signed-off-by: Christoph Hellwig <hch at lst.de>
> Reviewed-by: Chaitanya Kulkarni <kch at nvidia.com>
Is this basically an open-coded non-sb version of sb_bdev_nr_blocks()?
Reviewed-by: Kees Cook <keescook at chromium.org>
> ---
> drivers/target/target_core_iblock.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/target/target_core_iblock.c b/drivers/target/target_core_iblock.c
> index 31df20abe141f..b1ef041cacd81 100644
> --- a/drivers/target/target_core_iblock.c
> +++ b/drivers/target/target_core_iblock.c
> @@ -232,9 +232,9 @@ static unsigned long long iblock_emulate_read_cap_with_block_size(
> struct block_device *bd,
> struct request_queue *q)
> {
> - unsigned long long blocks_long = (div_u64(i_size_read(bd->bd_inode),
> - bdev_logical_block_size(bd)) - 1);
> u32 block_size = bdev_logical_block_size(bd);
> + unsigned long long blocks_long =
> + div_u64(bdev_nr_bytes(bd), block_size) - 1;
>
> if (block_size == dev->dev_attrib.block_size)
> return blocks_long;
> --
> 2.30.2
>
--
Kees Cook
More information about the Linux-nvme
mailing list