[PATCH 14/16] block: switch polling to be bio based
Pankaj Raghav
pankydev8 at gmail.com
Fri Oct 15 01:30:26 PDT 2021
On Tue, Oct 12, 2021 at 01:12:24PM +0200, Christoph Hellwig wrote:
> diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h
> index 2b80c98fc373e..2a8689e949b4c 100644
> --- a/include/linux/blkdev.h
> +++ b/include/linux/blkdev.h
> @@ -25,6 +25,7 @@ struct request;
> struct sg_io_hdr;
> struct blkcg_gq;
> struct blk_flush_queue;
> +struct kiocb;
> struct pr_ops;
> struct rq_qos;
> struct blk_queue_stats;
> @@ -550,7 +551,7 @@ static inline unsigned int blk_queue_depth(struct request_queue *q)
>
> extern int blk_register_queue(struct gendisk *disk);
> extern void blk_unregister_queue(struct gendisk *disk);
> -blk_qc_t submit_bio_noacct(struct bio *bio);
> +void submit_bio_noacct(struct bio *bio);
>
> extern int blk_lld_busy(struct request_queue *q);
> extern void blk_queue_split(struct bio **);
> @@ -568,7 +569,8 @@ blk_status_t errno_to_blk_status(int errno);
> #define BLK_POLL_ONESHOT (1 << 0)
> /* do not sleep to wait for the expected completion time */
> #define BLK_POLL_NOSLEEP (1 << 1)
Minor comment: Could we also have a flag #define BLK_POLL_SPIN 0?
It can improve the readability from the caller side instead of having
just a 0 to indicate spinning.
Regards,
Pankaj Raghav
More information about the Linux-nvme
mailing list