> - nvme_mpath_remove_disk(head); > +#ifdef CONFIG_NVME_MULTIPATH > + if (head->disk) > + put_disk(head->disk); > +#endif Please move this into a helper in multipath.c with a stub for the non-multipath case.