[PATCH 2/6] nvme: use 'nvmsXnZ' instead of 'nvm-subXnZ'
Hannes Reinecke
hare at suse.de
Mon Oct 2 06:55:55 PDT 2017
Align with overall nvme device naming scheme.
Signed-off-by: Hannes Reinecke <hare at suse.com>
---
drivers/nvme/host/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
index b1e61c9..f52f0ab 100644
--- a/drivers/nvme/host/core.c
+++ b/drivers/nvme/host/core.c
@@ -2689,7 +2689,7 @@ static struct nvme_ns_head *nvme_alloc_ns_head(struct nvme_ctrl *ctrl,
head->disk->private_data = head;
head->disk->queue = q;
head->disk->flags = GENHD_FL_EXT_DEVT;
- sprintf(head->disk->disk_name, "nvm-sub%dn%d",
+ sprintf(head->disk->disk_name, "nvms%dn%d",
ctrl->subsys->instance, nsid);
list_add_tail(&head->entry, &ctrl->subsys->nsheads);
return head;
--
1.8.5.6
More information about the Linux-nvme
mailing list