[PATCH] mtd: spi-nor: Decouple SPI NOR's device_node from controller device

Brian Norris computersforpeace at gmail.com
Tue Sep 1 17:30:17 PDT 2015


On Fri, Aug 21, 2015 at 11:16:21PM +0200, Marek Vasut wrote:
> On Friday, August 21, 2015 at 10:49:46 PM, Jonas Gorski wrote:
> > On Fri, Aug 21, 2015 at 8:34 PM, Marek Vasut <marex at denx.de> wrote:
> > > On Friday, August 21, 2015 at 04:15:11 PM, Jonas Gorski wrote:
> > >> > This patch is inspired by 5844feeaa4154d1c46d3462c7a4653d22356d8b4
> > >> > mtd: nand: add common DT init code
> > >> 
> > >> I know that this commit named it dn for nand, but IMHO "dn" isn't a
> > >> very readable member name, so I would suggest using something with
> > >> "node" in it (just using of_node as well seems to be common). I see no
> > >> place where the name length might become an issue.
> > > 
> > > I thought .dn was supposed to be abbrev for device_node ;-)
> > 
> > Sure, if you know what it is supposed to stand for it is obvious ;-).
> > And from a "stylistic" point of view, struct spi_nor has members
> > called page_size, flash_read or cmd_buf and not ps, fr, or cb so using
> > dn instead of e.g. dev_node seems a bit odd.
> 
> On the other hand, the .dn is consistent across the MTD subsystem.
> I don't have a strong prefference though.

I just stuck in nand_chip::dn since we needed something, and because
I've seen it used as a function parameter name and a local variable name
all over the place, enough that it just seemed natural. But a field name
is probably a bit more important. I'd be OK with making the "standard"
a bit more verbose, and maybe even changing the one in struct nand_chip.

How about:

  flash_node <-- this one leaves room for a controller node, if we
                 eventually need it
  device_node
  dev_node
  of_node <-- this one is commonly used, but mostly out of legacy
              reasons. We're not really dealing with Open Firmware

?

Pick one and run with it.

Brian



More information about the linux-mtd mailing list