[PATCH] UBIFS: Add /dev/ubiX_Y naming scheme in open_ubi

Corentin Chary corentin.chary at gmail.com
Mon Sep 28 07:53:25 EDT 2009


On Mon, Sep 28, 2009 at 1:39 PM, Artem Bityutskiy <dedekind1 at gmail.com> wrote:
> On Fri, 2009-09-25 at 00:47 +0200, Corentin Chary wrote:
>> This is needed to use $ mount /dev/ubi0_0 /mnt/nand
>> You'll also need a recent libblkid with UBI and UBIFS
>> support.
>>
>> Signed-off-by: Corentin Chary <corentincj at iksaif.net>
>> ---
>>  fs/ubifs/super.c |   12 ++++++++----
>>  1 files changed, 8 insertions(+), 4 deletions(-)
>>
>> diff --git a/fs/ubifs/super.c b/fs/ubifs/super.c
>> index 7e2b3d4..38320ad 100644
>> --- a/fs/ubifs/super.c
>> +++ b/fs/ubifs/super.c
>> @@ -1843,10 +1843,11 @@ const struct super_operations ubifs_super_operations = {
>>   * @mode: UBI volume open mode
>>   *
>>   * There are several ways to specify UBI volumes when mounting UBIFS:
>> - * o ubiX_Y    - UBI device number X, volume Y;
>> - * o ubiY      - UBI device number 0, volume Y;
>> - * o ubiX:NAME - mount UBI device X, volume with name NAME;
>> - * o ubi:NAME  - mount UBI device 0, volume with name NAME.
>> + * o /dev/ubiX_Y - UBI device number X, volume Y;
>> + * o ubiX_Y      - UBI device number X, volume Y;
>> + * o ubiY        - UBI device number 0, volume Y;
>> + * o ubiX:NAME   - mount UBI device X, volume with name NAME;
>> + * o ubi:NAME    - mount UBI device 0, volume with name NAME.
>>   *
>>   * Alternative '!' separator may be used instead of ':' (because some shells
>>   * like busybox may interpret ':' as an NFS host name separator). This function
>> @@ -1858,6 +1859,9 @@ static struct ubi_volume_desc *open_ubi(const char *name, int mode)
>>       int dev, vol;
>>       char *endptr;
>>
>> +     if (!strncmp("/dev/", name, 5))
>> +             name = name + 5;
>> +
>>       if (name[0] != 'u' || name[1] != 'b' || name[2] != 'i')
>>               return ERR_PTR(-EINVAL);
>
> But UBI volume may have arbitrary names. Could we invent something
> better?


Using name and kern_path we can find the corresponding inode (and
major/minor informations).
ubi_open_volume use ubi_num and vol_id.
vol_id is minor()-1, but major is not related to ubi_num.

UBI have a "ubi_major2num" internally, is it ok to export this symbol ?

Then we could do something like
ubi_open_volume(ubi_major2num(major()), minor()-1)

-- 
Corentin Chary
http://xf.iksaif.net



More information about the linux-mtd mailing list