struct jffs2_xattr_datum/jffs2_xattr_ref/jffs2_inode_cache

David Woodhouse dwmw2 at infradead.org
Mon May 22 22:26:01 EDT 2006


On Tue, 2006-05-23 at 11:01 +0900, KaiGai Kohei wrote:
> Now, I plan to implement that any versions of xattr_datum and
> xattr_ref are chained to physical node list and a real deletion
> of xattr_datum and xattr_ref should be called from
> jffs2_remove_node_refs_from_ino_list().

OK.

> By the way, I have a question about an usage for jffs2_reserve_space().
> 
> Is it permitted to allocate a space for multi nodes by a single
> calling of jffs2_reserve_space()?
> I tried to allocate a space for xattr_datum and xattr_ref by a single
> calling of jffs2_reserve_space(), and it seems to work without any
> troubles.

Yes, it works. But if you have space for just the xattr_datum at the end
of the eraseblock, it's better to write that in the available space and
then write the xattr_ref to the next eraseblock.

By the way, we should implement support for retrying writes in
save_xattr_datum() and save_xattr_ref(). See how jffs2_write_dnode() and
jffs2_write_dirent() do it, for example.

> If it's permitted, it's useful to reduce complexity by exclusion.
> What do you think about?

Once you implement the retry support, you don't reduce complexity, do
you?

-- 
dwmw2





More information about the linux-mtd mailing list