[PATCH v4 1/2] Bluetooth: btmtk: Replace magic numbers with WMT packet flag enum

Paul Menzel pmenzel at molgen.mpg.de
Tue Jun 23 00:13:13 PDT 2026


Dear Chris,


Thank you for the patch.

Am 23.06.26 um 05:41 schrieb Chris Lu:
> Add BTMTK_WMT_PKT_* enum to represent WMT download packet sequence flags,
> improving code readability. Replace magic numbers (1, 2, 3) in
> btmtk_setup_firmware_79xx() with descriptive enum values:
> 
> - BTMTK_WMT_PKT_START (1): First packet of a sequence
> - BTMTK_WMT_PKT_CONTINUE (2): Continuation packet
> - BTMTK_WMT_PKT_END (3): Final packet of a sequence
> 
> Signed-off-by: Chris Lu <chris.lu at mediatek.com>
> ---
>   drivers/bluetooth/btmtk.c | 6 +++---
>   drivers/bluetooth/btmtk.h | 6 ++++++
>   2 files changed, 9 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/bluetooth/btmtk.c b/drivers/bluetooth/btmtk.c
> index 02a96342e964..21c08ee1cdbf 100644
> --- a/drivers/bluetooth/btmtk.c
> +++ b/drivers/bluetooth/btmtk.c
> @@ -230,12 +230,12 @@ int btmtk_setup_firmware_79xx(struct hci_dev *hdev, const char *fwname,
>   			while (dl_size > 0) {
>   				dlen = min_t(int, 250, dl_size);
>   				if (first_block == 1) {
> -					flag = 1;
> +					flag = BTMTK_WMT_PKT_START;
>   					first_block = 0;
>   				} else if (dl_size - dlen <= 0) {
> -					flag = 3;
> +					flag = BTMTK_WMT_PKT_END;
>   				} else {
> -					flag = 2;
> +					flag = BTMTK_WMT_PKT_CONTINUE;
>   				}
>   
>   				wmt_params.flag = flag;
> diff --git a/drivers/bluetooth/btmtk.h b/drivers/bluetooth/btmtk.h
> index c83c24897c95..51c18dde0a80 100644
> --- a/drivers/bluetooth/btmtk.h
> +++ b/drivers/bluetooth/btmtk.h
> @@ -66,6 +66,12 @@ enum {
>   	BTMTK_WMT_ON_PROGRESS,
>   };
>   
> +enum {
> +	BTMTK_WMT_PKT_START = 1,
> +	BTMTK_WMT_PKT_CONTINUE = 2,
> +	BTMTK_WMT_PKT_END = 3,
> +};
> +
>   struct btmtk_wmt_hdr {
>   	u8	dir;
>   	u8	op;

Reviewed-by: Paul Menzel <pmenzel at molgen.mpg.de>


Kind regards,

Paul



More information about the Linux-mediatek mailing list