[PATCH 3/3] crypto: sl3516 - Use pm_runtime_resume_and_get()
Linus Walleij
linusw at kernel.org
Wed Sep 30 14:44:25 PDT 2026
On Tue, Sep 22, 2026 at 5:20 AM <phucduc.bui at gmail.com> wrote:
> From: bui duc phuc <phucduc.bui at gmail.com>
>
> Replace the open-coded pm_runtime_get_sync() + pm_runtime_put_noidle()
> error handling pattern with pm_runtime_resume_and_get(), which already
> does this internally.
>
> No functional change.
>
> Found by manual code inspection.
>
> Signed-off-by: bui duc phuc <phucduc.bui at gmail.com>
Reviewed-by: Linus Walleij <linusw at kernel.org>
Yours,
Linus Walleij
More information about the linux-arm-kernel
mailing list