[PATCH v2 18/21] arm64: entry: Split up kernel_ventry macro into separate helper macros

Linus Walleij linusw at kernel.org
Wed Sep 30 14:26:45 PDT 2026


On Fri, Sep 18, 2026 at 6:15 PM Will Deacon <will at kernel.org> wrote:

> Handling entry from EL0, EL1h and EL1t in the 'kernel_ventry' assembly
> macro is getting a bit unwieldy as the control flow becomes increasingly
> dependent on the macro arguments.
>
> Split 'kernel_ventry' into three leaf helper macros for EL0, EL1h and
> EL1t, which are then dispatched by simple wrappers.
>
> Signed-off-by: Will Deacon <will at kernel.org>

I agree with this change, this is easier to read and understand.
Reviewed-by: Linus Walleij <linusw at kernel.org>

Yours,
Linus Walleij



More information about the linux-arm-kernel mailing list