[PATCH v1 5/6] KVM: arm64: Use kvm_s2_fault_vma_info in gmem_abort()
Fuad Tabba
fuad.tabba at linux.dev
Mon Sep 28 00:44:33 PDT 2026
Hi Marc, Wei-Lin,
On Sun, 27 Sep 2026 17:30:04 +0100, Marc Zyngier <maz at kernel.org> wrote:
[...]
> > Perhaps it is worth reserving plain "gfn" for the value we use as the
> > IA of the (shadow) page table, and name this variable something like
> > canonical_gfn. Similar to what kvm_s2_fault_map() does.
>
> Maybe. We have gfn in the vncr fault handling code as well, but that
> one is the result of a S1 walk, so maybe more obvious.
Agreed, now that s2vi.gfn sits next to it. I'll rename it to
canonical_gfn for v2.
> > Huh, I guess you also fixed a bug here? s2fd->fault_ipa could be the
> > nested ipa instead of the canonical ipa.
>
> Yeah, it appears so. Worth capturing in Fixes: as well.
That one came in with a7b57e0995927 too, so the existing Fixes: covers
it. I'll mention it in the commit message.
Cheers,
/fuad
More information about the linux-arm-kernel
mailing list