[PATCH v3 14/14] audit: rename audit_syscall_entry_regs() to audit_syscall_entry()
Oleg Nesterov
oleg at redhat.com
Wed Sep 23 04:30:12 PDT 2026
On 09/22, Ricardo Robaina wrote:
>
> Now that every architecture has been converted to the pt_regs-based
> audit_syscall_entry_regs(), the legacy audit_syscall_entry() and
> __audit_syscall_entry() helpers that took the individual syscall
> argument registers (a0-a3) no longer have any callers.
>
> Remove those legacy helpers and rename audit_syscall_entry_regs() and
> __audit_syscall_entry_regs() back to audit_syscall_entry() and
> __audit_syscall_entry(), restoring the original naming.
>
> The _regs variants were introduced separately, and the architectures
> converted one per patch, specifically so this final rename is the only
> step that removes the old prototype. That keeps the series bisectable:
> every commit builds, and no caller is ever left referencing a helper
> that has been removed.
>
> Suggested-by: Will Deacon <will at kernel.org>
> Signed-off-by: Ricardo Robaina <rrobaina at redhat.com>
Reviewed-by: Oleg Nesterov <oleg at redhat.com>
More information about the linux-arm-kernel
mailing list