[PATCH v12 5/7] virt: coco: arm-cca-guest: Rename TSM report source file
Jonathan Cameron
jonathan.cameron at oss.qualcomm.com
Mon Sep 21 15:25:50 PDT 2026
On Mon, 21 Sep 2026 11:08:05 +0530
"Aneesh Kumar K.V (Arm)" <aneesh.kumar at kernel.org> wrote:
> The Arm CCA guest driver currently only implements TSM report support, but
> follow-up changes will add more TSM-related functionality to the same
> module.
>
> Rename arm-cca-guest.c to main.c and build it as an object of the
> arm-cca-guest module. This leaves room for the module to grow additional
> source files.
>
> Also rename the arm_cca_tsm_ops instance to arm_cca_tsm_report_ops to
> distinguish the report operations from other TSM functionality that will
> be added.
>
> Reviewed-by: Suzuki K Poulose <suzuki.poulose at arm.com>
> Reviewed-by: Catalin Marinas <catalin.marinas at arm.com>
> Reviewed-by: Jason Gunthorpe <jgg at nvidia.com>
> Signed-off-by: Aneesh Kumar K.V (Arm) <aneesh.kumar at kernel.org>
Reviewed-by: Jonathan Cameron <jonathan.cameron at oss.qualcomm.com>
More information about the linux-arm-kernel
mailing list