[PATCH v3 2/4] dmaengine: loongson: use named initializers for acpi_device_id

Frank Li Frank.li at oss.nxp.com
Wed Sep 16 12:12:03 PDT 2026


On Wed, Sep 16, 2026 at 04:27:55PM +0100, Pawel Zalewski wrote:
> Use a named initializer for the acpi_device_id fields which makes the code
> more readable and consistent with how lists are initialized in the rest of
> the kernel code base.
>
> Unify the list terminator to have a single space between the brackets and
> no trailing comma.
>
> Signed-off-by: Pawel Zalewski <pzalewski at thegoodpenguin.co.uk>
> Reviewed-by: Binbin Zhou <zhoubinbin at loongson.cn>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko at linux.intel.com>
> ---

Reviewed-by: Frank Li <Frank.Li at nxp.com>

>  drivers/dma/loongson/loongson2-apb-cmc-dma.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/dma/loongson/loongson2-apb-cmc-dma.c b/drivers/dma/loongson/loongson2-apb-cmc-dma.c
> index 1c9a542edc859..70880625c6e92 100644
> --- a/drivers/dma/loongson/loongson2-apb-cmc-dma.c
> +++ b/drivers/dma/loongson/loongson2-apb-cmc-dma.c
> @@ -709,8 +709,8 @@ static const struct of_device_id loongson2_cmc_dma_of_match[] = {
>  MODULE_DEVICE_TABLE(of, loongson2_cmc_dma_of_match);
>
>  static const struct acpi_device_id loongson2_cmc_dma_acpi_match[] = {
> -	{ "LOON0014", .driver_data = (kernel_ulong_t)&ls2k3000_cmc_dma_config },
> -	{ /* sentinel */ }
> +	{ .id = "LOON0014", .driver_data = (kernel_ulong_t)&ls2k3000_cmc_dma_config },
> +	{ }
>  };
>  MODULE_DEVICE_TABLE(acpi, loongson2_cmc_dma_acpi_match);
>
>
> --
> 2.43.0
>



More information about the linux-arm-kernel mailing list