[PATCH] crypto: sun8i-ce - Use kcalloc() instead of kzalloc()

Gustavo A. R. Silva gustavo at embeddedor.com
Mon Jan 22 09:53:45 PST 2024



On 1/21/24 09:34, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the purpose specific kcalloc() function instead of the argument
> size * count in the kzalloc() function.
> 
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer at gmx.com>

Reviewed-by: Gustavo A. R. Silva <gustavoars at kernel.org>

Thanks!
-- 
Gustavo

> ---
>   drivers/crypto/allwinner/sun8i-ce/sun8i-ce-hash.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/crypto/allwinner/sun8i-ce/sun8i-ce-hash.c b/drivers/crypto/allwinner/sun8i-ce/sun8i-ce-hash.c
> index d358334e5981..ee2a28c906ed 100644
> --- a/drivers/crypto/allwinner/sun8i-ce/sun8i-ce-hash.c
> +++ b/drivers/crypto/allwinner/sun8i-ce/sun8i-ce-hash.c
> @@ -362,7 +362,7 @@ int sun8i_ce_hash_run(struct crypto_engine *engine, void *breq)
>   		digestsize = SHA512_DIGEST_SIZE;
> 
>   	/* the padding could be up to two block. */
> -	buf = kzalloc(bs * 2, GFP_KERNEL | GFP_DMA);
> +	buf = kcalloc(2, bs, GFP_KERNEL | GFP_DMA);
>   	if (!buf) {
>   		err = -ENOMEM;
>   		goto theend;
> --
> 2.25.1
> 



More information about the linux-arm-kernel mailing list