[PATCH v2 05/26] media: go7007: Use min and max macros
Bryan O'Donoghue
bryan.odonoghue at linaro.org
Sat Apr 20 16:11:51 PDT 2024
On 19/04/2024 10:47, Ricardo Ribalda wrote:
> It makes the code simpler and cocci happier:
>
> drivers/media/usb/go7007/go7007-fw.c:1292:14-15: WARNING opportunity for max()
> drivers/media/usb/go7007/go7007-fw.c:1293:14-15: WARNING opportunity for min()
>
> Signed-off-by: Ricardo Ribalda <ribalda at chromium.org>
> ---
> drivers/media/usb/go7007/go7007-fw.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/media/usb/go7007/go7007-fw.c b/drivers/media/usb/go7007/go7007-fw.c
> index 018019ba47d4..86ce593e0c54 100644
> --- a/drivers/media/usb/go7007/go7007-fw.c
> +++ b/drivers/media/usb/go7007/go7007-fw.c
> @@ -1289,8 +1289,8 @@ static int avsync_to_package(struct go7007 *go, __le16 *code, int space)
> 0xbf99, (u16)((-adjratio) >> 16),
> 0xbf92, 0,
> 0xbf93, 0,
> - 0xbff4, f1 > f2 ? f1 : f2,
> - 0xbff5, f1 < f2 ? f1 : f2,
> + 0xbff4, max(f1, f2),
> + 0xbff5, min(f1, f2),
> 0xbff6, f1 < f2 ? ratio : ratio + 1,
> 0xbff7, f1 > f2 ? ratio : ratio + 1,
> 0xbff8, 0,
>
Code is correct, but the commit log could use some expansion.
Suggest:
"Replace ternary inline selection of f1 and f2 min max values with min()
and max() helper functions for the sake of readability and to make
coccinelle happier"
You can take the RB either way though
Reviewed-by: Bryan O'Donoghue <bryan.odonoghue at linaro.org>
More information about the linux-arm-kernel
mailing list