[PATCH v3 04/11] hv: Use driver_set_override() instead of open-coding

Michael Kelley (LINUX) mikelley at microsoft.com
Sun Feb 27 07:53:00 PST 2022


From: Krzysztof Kozlowski <krzysztof.kozlowski at canonical.com> Sent: Sunday, February 27, 2022 5:52 AM
> 
> Use a helper for seting driver_override to reduce amount of duplicated
> code. Make the driver_override field const char, because it is not
> modified by the core and it matches other subsystems.
> 
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski at canonical.com>
> ---
>  drivers/hv/vmbus_drv.c | 28 ++++------------------------
>  include/linux/hyperv.h |  7 ++++++-
>  2 files changed, 10 insertions(+), 25 deletions(-)
> 
> diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
> index 12a2b37e87f3..a0ff4139c3d2 100644
> --- a/drivers/hv/vmbus_drv.c
> +++ b/drivers/hv/vmbus_drv.c
> @@ -575,31 +575,11 @@ static ssize_t driver_override_store(struct device *dev,
>  				     const char *buf, size_t count)
>  {
>  	struct hv_device *hv_dev = device_to_hv_device(dev);
> -	char *driver_override, *old, *cp;
> -
> -	/* We need to keep extra room for a newline */
> -	if (count >= (PAGE_SIZE - 1))
> -		return -EINVAL;
> -
> -	driver_override = kstrndup(buf, count, GFP_KERNEL);
> -	if (!driver_override)
> -		return -ENOMEM;
> -
> -	cp = strchr(driver_override, '\n');
> -	if (cp)
> -		*cp = '\0';
> -
> -	device_lock(dev);
> -	old = hv_dev->driver_override;
> -	if (strlen(driver_override)) {
> -		hv_dev->driver_override = driver_override;
> -	} else {
> -		kfree(driver_override);
> -		hv_dev->driver_override = NULL;
> -	}
> -	device_unlock(dev);
> +	int ret;
> 
> -	kfree(old);
> +	ret = driver_set_override(dev, &hv_dev->driver_override, buf, count);
> +	if (ret)
> +		return ret;
> 
>  	return count;
>  }
> diff --git a/include/linux/hyperv.h b/include/linux/hyperv.h
> index fe2e0179ed51..beea11874be2 100644
> --- a/include/linux/hyperv.h
> +++ b/include/linux/hyperv.h
> @@ -1257,7 +1257,12 @@ struct hv_device {
>  	u16 device_id;
> 
>  	struct device device;
> -	char *driver_override; /* Driver name to force a match */
> +	/*
> +	 * Driver name to force a match.
> +	 * Do not set directly, because core frees it.
> +	 * Use driver_set_override() to set or clear it.
> +	 */
> +	const char *driver_override;
> 
>  	struct vmbus_channel *channel;
>  	struct kset	     *channels_kset;
> --
> 2.32.0

Reviewed-by: Michael Kelley <mikelley at microsoft.com>




More information about the linux-arm-kernel mailing list