[PATCH 2/2] arm64: dts: freescale: Add LVDS overlay for TQMa8MPxL

Richard Leitner richard.leitner at linux.dev
Tue Dec 20 00:48:45 PST 2022


Hi Alexander,

thanks for the series.

On Thu, Dec 08, 2022 at 10:08:42AM +0100, Alexander Stein wrote:
> This adds an overlay for the supported LVDS display tianma tm070jvhg33.
> The display timings have to be specified explicitly. Using the typical pixel
> clock, the LDB clock can not be configured as the 7-fold of that.
> By setting pixel clock to 74.25 MHz, LDB can be configured to exactly
> 519.75 MHz.
> 
> Signed-off-by: Alexander Stein <alexander.stein at ew.tq-group.com>
> ---
> To be hold I'm unsure where to list the overlays. I checked other overlays
> and opted to added them at the end of imx8mp section.
> 
>  arch/arm64/boot/dts/freescale/Makefile        |  4 ++
>  .../imx8mp-tqma8mpql-mba8mpxl-lvds.dtso       | 61 +++++++++++++++++++
>  2 files changed, 65 insertions(+)
>  create mode 100644 arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso

...

> diff --git a/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso b/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso
> new file mode 100644
> index 0000000000000..ea44d605342ba
> --- /dev/null
> +++ b/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso
> @@ -0,0 +1,61 @@
> +// SPDX-License-Identifier: (GPL-2.0-or-later OR MIT)
> +/*
> + * Copyright (c) 2022 TQ-Systems GmbH <linux at ew.tq-group.com>,
> + * D-82229 Seefeld, Germany.
> + * Author: Alexander Stein
> + */
> +
> +/dts-v1/;
> +/plugin/;
> +
> +&{/} {
> +	compatible = "tq,imx8mp-tqma8mpql-mba8mpxl", "tq,imx8mp-tqma8mpql", "fsl,imx8mp";
> +};
> +
> +&backlight_lvds {
> +	status = "okay";
> +};
> +
> +&display {
> +	compatible = "tianma,tm070jvhg33";
> +	status = "okay";
> +
> +	panel-timing {
> +		clock-frequency = <74250000>;
> +		hactive = <1280>;
> +		vactive = <800>;
> +		hfront-porch = <64>;
> +		hback-porch = <5>;
> +		hsync-len = <1>;
> +		vfront-porch = <40>;
> +		vback-porch = <2>;
> +		vsync-len = <1>;
> +		de-active = <1>;
> +	};
> +
> +	port {
> +		panel_in_lvds0: endpoint {
> +			remote-endpoint = <&ldb_lvds_ch0>;
> +		};
> +	};
> +};
> +
> +&lcdif2 {
> +	status = "okay";
> +};
> +
> +&lvds_bridge {
> +	status = "okay";
> +
> +	ports {
> +		port at 1 {
> +			ldb_lvds_ch0: endpoint {
> +				remote-endpoint = <&panel_in_lvds0>;
> +			};
> +		};
> +	};
> +};

Wouldn't it be possible and easier to read if this was &ldb_lvds_ch0
only instead of the "whole" &lvds_bridge?

&ldb_lvds_ch0 {
	remote-endpoint = <&panel_in_lvds0>;
};

> +
> +&pwm2 {
> +	status = "okay";
> +};
> -- 
> 2.34.1
> 

regards;rl



More information about the linux-arm-kernel mailing list