[PATCH 0/6] arm64: stacktrace cleanups

Mark Rutland mark.rutland at arm.com
Wed Apr 13 07:59:04 PDT 2022


This series is a collection of cleanup / refactoring changes for the
arm64 stacktrace code.

There should be no functional change as a result of this series; the
bulk of the series is a rename for consistency with the core+x86 unwind
code, and the only structural changes are the removal of a redundant
NULL check and making some code private to
arch/arm64/kernel/stacktrace.c.

The bulk of the series has been extracted from v13 of Madhavan's series
adding reliability checks:

  https://lore.kernel.org/linux-arm-kernel/20220117145608.6781-1-madvenka@linux.microsoft.com/

... and I've rebased the extracted patches atop v5.18-rc1. The rest of
that series needs further review, and I'd like to get the
uncontroversial bits out of the way now while that continues so that we
can make other changes in this area.

The couple of patches from me are new as of this posting, but I'm hoping
those are simple enough that this can be picked up as-is.

The series can be found in my arm64/stacktrace/cleanups branch:

  https://git.kernel.org/pub/scm/linux/kernel/git/mark/linux.git/log/?h=arm64/stacktrace/cleanups
  git://git.kernel.org/pub/scm/linux/kernel/git/mark/linux.git arm64/stacktrace/cleanups

Thanks,
Mark.

Madhavan T. Venkataraman (4):
  arm64: stacktrace: remove NULL task check from unwind_frame()
  arm64: stacktrace: rename unwinder functions
  arm64: stacktrace: rename stackframe to unwind_state
  arm64: stacktrace: align with common naming

Mark Rutland (2):
  arm64: stacktrace: delete PCS comment
  arm64: stacktrace: make struct stackframe private to stacktrace.c

 arch/arm64/include/asm/stacktrace.h |  32 -------
 arch/arm64/kernel/stacktrace.c      | 124 ++++++++++++++++------------
 2 files changed, 69 insertions(+), 87 deletions(-)

-- 
2.30.2




More information about the linux-arm-kernel mailing list