[PATCH v2 12/13] ARM: dts: imx: add i.MXRT1050-EVK support

Jesse Taube mr.bossman075 at gmail.com
Tue Nov 2 16:54:33 PDT 2021



On 11/2/21 19:42, Fabio Estevam wrote:
> On Tue, Nov 2, 2021 at 7:57 PM Jesse Taube <mr.bossman075 at gmail.com> wrote:
> 
>> +/ {
>> +       model = "NXP IMXRT1050-evk board";
>> +       compatible = "fsl,imxrt1050-evk", "fsl,imxrt1050";
>> +
>> +       chosen {
>> +               bootargs = "root=/dev/ram";
> 
> No need to pass bootargs here.
> 
>> +               stdout-path = &lpuart1;
>> +       };
>> +
>> +       aliases {
>> +               gpio0 = &gpio1;
>> +               gpio1 = &gpio2;
>> +               gpio2 = &gpio3;
>> +               gpio3 = &gpio4;
>> +               gpio4 = &gpio5;
>> +               mmc0 = &usdhc1;
>> +               serial0 = &lpuart1;
>> +       };
>> +
>> +       memory at 0 {
> 
> memory at 80000000
> 
> Building with W=1 should give a dtc warning due to the unit address
> and reg mismatch.
Oh that makes sense.
I guess I'm going to have to figure out how to get warnings to work as I 
couldn't last time I tried.
> 
>> +               device_type = "memory";
>> +               reg = <0x80000000 0x2000000>;
>> +       };
>> +
> 
> Unneeded blank line.
>> +
>> +&iomuxc {
>> +       pinctrl-names = "default";
>> +
>> +       imxrt1050-evk {
> 
> No need for this imxrt1050-evk container.
I was wondering if that was needed, u-boot has it, good to know.
> 
>> +               pinctrl_lpuart1: lpuart1grp {
>> +                       fsl,pins = <
>> +                               MXRT1050_IOMUXC_GPIO_AD_B0_12_LPUART1_TXD
>> +                                       0xf1
> 
> Put it on a single line. It helps readability. Same applies globally.
>> +&usdhc1 {
>> +       pinctrl-names = "default", "state_100mhz", "state_200mhz", "sleep";
>> +       pinctrl-0 = <&pinctrl_usdhc0>;
>> +       pinctrl-1 = <&pinctrl_usdhc0>;
>> +       pinctrl-2 = <&pinctrl_usdhc0>;
>> +       pinctrl-3 = <&pinctrl_usdhc0>;
>> +       status = "okay";
>> +
>> +       cd-gpios = <&gpio2 28 GPIO_ACTIVE_LOW>;
> 
> Make 'status' to be the last property. Remove the blank line.
> 
>> +               edma1: dma-controller at 400e8000 {
>> +                       #dma-cells = <2>;
>> +                       compatible = "fsl,imx7ulp-edma";
>> +                       reg = <0x400e8000 0x4000>,
>> +                               <0x400ec000 0x4000>;
>> +                       dma-channels = <32>;
>> +                       interrupts = <0>,
>> +                               <1>,
>> +                               <2>,
>> +                               <3>,
>> +                               <4>,
>> +                               <5>,
>> +                               <6>,
>> +                               <7>,
>> +                               <8>,
>> +                               <9>,
>> +                               <10>,
>> +                               <11>,
>> +                               <12>,
>> +                               <13>,
>> +                               <14>,
>> +                               <15>,
>> +                               <16>;
> 
> Please group more elements into the same line.
> 
> Putting one entry per line makes it extremely long.
> 
>> +               gpio5: gpio at 400c0000 {
>> +                       compatible = "fsl,imxrt-gpio", "fsl,imx35-gpio";
>> +                       reg = <0x400c0000 0x4000>;
>> +                       interrupts = <88>,
>> +                               <89>;
> 
> Put the interrupts into a single line.
> 
Ah all these make sense, will fix, sry about that.



More information about the linux-arm-kernel mailing list