[PATCHv2 2/3] arm64: cpufeature: reorder cpus_have_{const,final}_cap()

Mark Rutland mark.rutland at arm.com
Fri Oct 30 10:18:51 EDT 2020


On Fri, Oct 30, 2020 at 08:20:14AM +0000, Will Deacon wrote:
> On Fri, Oct 30, 2020 at 08:18:48AM +0000, Will Deacon wrote:
> > On Mon, Oct 26, 2020 at 01:49:30PM +0000, Mark Rutland wrote:
> > > In a subsequent patch we'll modify cpus_have_const_cap() to call
> > > cpus_have_final_cap(), and hence we need to define cpus_have_final_cap()
> > > first.
> > > 
> > > To make subsequent changes easier to follow, this patch reorders the two
> > > without making any other changes.
> > > 
> > > There should be no functional change as a result of this patch.
> > 
> > You say this...

[...]

> > > -static __always_inline bool cpus_have_const_cap(int num)
> > > +static __always_inline bool cpus_have_final_cap(int num)
> > >  {
> > >  	if (system_capabilities_finalized())
> > >  		return __cpus_have_const_cap(num);
> > >  	else
> > > -		return cpus_have_cap(num);
> > > +		BUG();
> > 
> > ... but isn't the failure case of calling cpus_have_final_cap() early now
> > different? What does BUG() do at EL2 w/ nVHE?
> 
> Ah no, sorry, I see you're just moving things around and the diff makes it
> look confusing (that and I've been up since 5:30 for KVM Forum).

Indeed; the diff was even more confusing before I split this from the
changes in the next patch!

> So on closer inspection:
> 
> Acked-by: Will Deacon <will at kernel.org>

Cheers!

Mark.



More information about the linux-arm-kernel mailing list