[PATCH V6 18/26] coresight: etb10: implementing AUX space API

Mathieu Poirier mathieu.poirier at linaro.org
Fri Dec 11 13:17:12 PST 2015


On 11 December 2015 at 07:00, Alexander Shishkin
<alexander.shishkin at linux.intel.com> wrote:
> Mathieu Poirier <mathieu.poirier at linaro.org> writes:
>
>> +static void *etb_get_config(struct coresight_device *csdev, int cpu,
>> +                         void **pages, int nr_pages, bool overwrite)
>> +{
>> +     int node;
>> +     struct cs_buffers *buf;
>> +
>> +     if (cpu == -1)
>> +             cpu = smp_processor_id();
>> +     node = cpu_to_node(cpu);
>> +
>> +     buf = kzalloc_node(sizeof(struct cs_buffers), GFP_KERNEL, node);
>> +     if (!buf)
>> +             return NULL;
>> +
>> +     buf->snapshot = overwrite;
>> +     buf->nr_pages = nr_pages;
>> +     buf->data_pages = pages;
>> +
>> +     return buf;
>> +}
>
> Nitpick: why is this called "get_config"? I was just looking for
> something else and noticed that both sources and sinks have
> .get_config() callback (I was looking for the source's one), but this
> guy doesn't seem to be getting any config, but rather allocating a
> buffer descriptor.

My goal was to harmonise the naming convention between source and
sinks as much as possible, and I'm still not quite sure how to call
that function... Given the end result something like
"etb_alloc_buffer" would likely be more appropriate.

>
> Regards,
> --
> Alex



More information about the linux-arm-kernel mailing list