[PATCH v4 1/2] of: Rename "poweroff-source" property to "system-power-controller"
heiko at sntech.de
Mon Nov 24 05:12:19 PST 2014
Am Montag, 24. November 2014, 14:01:02 schrieb Romain Perier:
> 2014-11-24 13:58 GMT+01:00 Romain Perier <romain.perier at gmail.com>:
> > So I need to resend this patch which would only introduce an helper
> > function which checks for "system-power-controller" property (it would
> > also have a new commit message).
> > As you suggested, this helper might be named
> > "of_device_is_system_power_controller" ?
> I mean, the backward compatibility can be handled directly from the
> device driver which would use the new property, no ?
yep, that is what Grant asked for ... to have drivers that need backward-
compatibility (like with the "ti,"-prefix) to do this themselfs.
More information about the linux-arm-kernel