[PATCH v4 1/2] of: Rename "poweroff-source" property to "system-power-controller"

Romain Perier romain.perier at gmail.com
Mon Nov 24 04:58:50 PST 2014

2014-11-24 12:35 GMT+01:00 Johan Hovold <johan at kernel.org>:
> On Mon, Nov 24, 2014 at 10:24:56AM +0000, Lee Jones wrote:
>> On Fri, 21 Nov 2014, Johan Hovold wrote:
>> > On Thu, Nov 13, 2014 at 01:34:58PM +0000, Auto Configured wrote:
>> > > From: Romain Perier <romain.perier at gmail.com>
>> > >
>> > > It reverts commit a4b4e0461ec5 ("of: Add standard property for poweroff capability").
>> > > As discussed on the mailing list, it makes more sense to rename back to the
>> > > old established property name, without the vendor prefix. Problem being that
>> > > the word "source" usually tends to be used for inputs and that is out of control
>> > > of the OS. The poweroff capability is an output which simply turns the
>> > > system-power off. Also, this property might be used by drivers which power-off
>> > > the system and power back on subsequent RTC alarms. This seems to suggest to
>> > > remove "poweroff" from the property name and to choose "system-power-controller"
>> > > as the more generic name. This patchs adds the required renaming changes and
>> > > defines an helper function which is compatible with both properties, the old one
>> > > which was only used by tps65910 and the new one without vendor-prefix.
>> >
>> > Now this is a bit of a mess.
>> >
>> > There's a commit in the mfd tree, 25f833c1171d ("mfd: tps65910: Convert
>> > ti,system-power-controller DT property to poweroff-source"), which
>> > breaks all dts using tps65910 since these are never updated to the now
>> > retracted property name ("poweroff-source").
>> My word!
>> Romain, what conversation on the MLs are you talking about?
> I think Romain is referring to this thread:
>         https://lkml.org/lkml/2014/10/23/161

Yes, this is this one.

>> > This one should simply be reverted ASAP.
>> No need to revert, I can just remove the patch from the MFD tree.
> Ok, good. Then this is limited to the regulator tree, and we could
> proceed as I outlined below.
> Romain, care to resend this patch without the tps65910 chunks?

If you can just drop the patch from mfd tree Lee, please do.
Yes Johan, np, what I want is that we find a smart solution, nothing more.

> You should also fix the commit message, which claims to define a "helper
> function which is compatible with both properties", something which was
> no longer the case.
> Thanks,
> Johan

So I need to resend this patch which would only introduce an helper
function which checks for "system-power-controller" property (it would
also have a new commit message).
As you suggested, this helper might be named
"of_device_is_system_power_controller" ?

Everything is okay ?


More information about the linux-arm-kernel mailing list