[PATCHv0 3/3] rtc: rtc-isl12057: add alarm support to Intersil ISL12057 RTC driver

Guenter Roeck linux at roeck-us.net
Wed Nov 5 21:59:47 PST 2014

On 11/05/2014 09:50 PM, Mark Brown wrote:
> On Wed, Nov 05, 2014 at 10:42:52PM +0100, Arnaud Ebalard wrote:
>> +static int _isl12057_rtc_toggle_alarm(struct device *dev, int enable)
>> +{
>> +	struct isl12057_rtc_data *data = dev_get_drvdata(dev);
> I can't help but think that toggle is a confusing name for this.
> enable?
If I recall correctly we had this argument before. Problem is that the
function can also _disable_ the alarm, so to name it enable is just
as misleading or confusing. update_alarm, maybe ?


More information about the linux-arm-kernel mailing list