[PATCH v3 13/19] arm/arm64: KVM: add vgic.h header file

Christoffer Dall christoffer.dall at linaro.org
Tue Nov 4 11:30:22 PST 2014

On Fri, Oct 31, 2014 at 05:26:48PM +0000, Andre Przywara wrote:
> vgic.c is currently a mixture of generic vGIC emulation code and
> functions specific to emulating a GICv2. To ease the addition of
> GICv3 later, we create new header file vgic.h, which holds constants
> and prototypes of commonly used functions.
> I removed the long-standing comment about using the kvm_io_bus API
> to tackle the GIC register ranges, as it wouldn't be a win for us
> anymore.
> Signed-off-by: Andre Przywara <andre.przywara at arm.com>
> -------
> As the diff isn't always obvious here (and to aid eventual rebases),
> here is a list of high-level changes done to the code:
> * moved definitions and prototypes from vgic.c to vgic.h:
>   - vgic_update_state()
>   - vgic_kick_vcpus()
>   - vgic_get_vmcr()
>   - vgic_set_vmcr()
>   - struct mmio_range {}
>   - IS_IN_RANGE() macro

should we worry about generic names now being exported and think about
renaming to things like kvm_mmio_range ?

(For the record, I'm not a strong proponent of this idea, just thought
it better to raise the issue now than later.)


Acked-by: Christoffer Dall <christoffer.dall at linaro.org>

More information about the linux-arm-kernel mailing list