[PATCH 4/4] ARM: bcm281xx: Rename board_init() function

Markus Mayer markus.mayer at linaro.org
Tue Feb 25 17:17:46 EST 2014


Rename board_init() to bcm281xx_init(), so the name reflects the board
specific nature of this function.

Signed-off-by: Markus Mayer <markus.mayer at linaro.org>
---
 arch/arm/mach-bcm/board_bcm281xx.c |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/arm/mach-bcm/board_bcm281xx.c b/arch/arm/mach-bcm/board_bcm281xx.c
index fe00ff3..8fee05b 100644
--- a/arch/arm/mach-bcm/board_bcm281xx.c
+++ b/arch/arm/mach-bcm/board_bcm281xx.c
@@ -56,7 +56,7 @@ static void bcm281xx_restart(enum reboot_mode mode, const char *cmd)
 	while (1);
 }
 
-static void __init board_init(void)
+static void __init bcm281xx_init(void)
 {
 	of_platform_populate(NULL, of_default_bus_match_table, NULL,
 		&platform_bus);
@@ -66,7 +66,7 @@ static void __init board_init(void)
 static const char * const bcm11351_dt_compat[] = { "brcm,bcm11351", NULL, };
 
 DT_MACHINE_START(BCM11351_DT, "BCM281xx Broadcom Application Processor")
-	.init_machine = board_init,
+	.init_machine = bcm281xx_init,
 	.restart = bcm281xx_restart,
 	.dt_compat = bcm11351_dt_compat,
 MACHINE_END
-- 
1.7.9.5




More information about the linux-arm-kernel mailing list