[PATCH] ARM: locks: remove opencoded #16 for ticket shift

Nicolas Pitre nico at linaro.org
Wed Jul 17 09:56:59 EDT 2013


On Mon, 15 Jul 2013, Will Deacon wrote:

> The ticket width of our spinlocks is defined by TICKET_SHIFT, so remove
> the opencoded #16 from the trylock implementation.
> 
> Signed-off-by: Will Deacon <will.deacon at arm.com>

This is pointless.

>  		"	ldrex	%0, [%3]\n"
>  		"	mov	%2, #0\n"
> -		"	subs	%1, %0, %0, ror #16\n"

Any value other than 16 would break that code.  You'd rather ensure it 
never gets defined to anything else.


Nicolas



More information about the linux-arm-kernel mailing list