[PATCH 07/10] MCDE: Add display subsystem framework

Arnd Bergmann arnd at arndb.de
Fri Nov 12 11:38:53 EST 2010


On Wednesday 10 November 2010, Jimmy Rubin wrote:
> This patch adds support for the MCDE, Memory-to-display controller,
> found in the ST-Ericsson ux500 products.
> 
> This patch adds a display subsystem framework that can be used
> by a frame buffer device driver to control a display and MCDE.

Like "hardware abstraction layer", "framework" is another term that
we do not like to hear. We write drivers that drive specific hardware,
so better name it after the exact part of the chip that it is driving.

Other terms to avoid include "middleware", "generic subsystem" and
"wrapper".

> +struct kobj_type ovly_type = {
> +	.release = overlay_release,
> +};

You certainly should not define a new kobj_type for use in a device driver.
This is an internal data structure of the linux core code. It might make
sense if you were trying to become the new frame buffer layer maintainer
and rewrite all the existing drivers to be based on the concept of
overlays, but even then there is probably a better way.

Maybe you were thinking of using kref instead of kobj?

> +int __init mcde_dss_init(void)
> +{
> +	return 0;
> +}
> +
> +void mcde_dss_exit(void)
> +{
> +}

If they don't do anything, don't define them.

	Arnd



More information about the linux-arm-kernel mailing list